Accueil / Technique [Electronique-Electrique]

[Tous Modèles] Régulateur, Informations techniques sur le saut de vitesse

barn
Membre d'honneur
Message Dim 20 Mar, 2005 21:03
[Douggy : Ce post détaille le fonctionnement des sauts de vitesse avec le régulateur, on commence par un petit rappel de Barn sur la vitesse réelle/lue ;-) ]

Petit truc :
Rouler à 120 stabilisé
Reset de la vitesse moy à l'OdB
Surveiller la vitesse moy
au bout de 800m, elle est à nouveau calculée
Resultat : 116 km/H
C'est votre vitesse réelle

Les compteurs ont une courbe d'avance, c-a-d qu'en fonction de la vitesse réelle, ils affichent un peu plus. Et cet "un peu plus" dépend de la vitesse. Mais il est répétable. C'est calibré.

Fait cela pour plusieurs vitesses, votre compteur est étalonné.

J'ai joué à passer devant un radar auto (90 km/h): tous les matins en allant au boulot, j'augmentait la vitesse de 1km/h. Jusqu'à 94 réel, ca passe, soit un petit 98 affiché, je crois. A vérifier.
Dernière édition par Accordiola1 le Sam 16 Aoû, 2008 10:08; édité 1 fois
tuxcarnav a écrit:
Bouboune a écrit:

Encore un problème de communication de la part de Renault : ce dysfonctionnement n'est pas un bug de logiciel ! C'est une mauvaise conception de la fonction qui transforme la vitesse réelle enregistrée lors de l'activation du régulateur (cette vitesse n'est pas un entier, il y a une virgule et des chiffres derrière) en une vitesse paire affichable au tableau de bord. Cette transformation a mal été conçue, mais le logiciel est lui parfaitement conforme, et bête et méchant il reproduit le phénomène, qui n'est pas grave certes, mais ne fait vraiment pas très sérieux, je te l'accorde !


Salut,

Par exemple (vécu récemment) : je roule à une vitesse proche de 120 km/h, je sélectionne le limiteur, j'appuie sur [+], l'afficheur indique 122. Je décide de mettre la consigne à 134 km/h, à l'aide de la touche [+] j'augmente la vitesse de consigne, dans le même temps je ne touche pas à l'accélérateur et la voiture reste autour de 120 km/h. Jusqu'à 132, pas de problème, mais l'appui suivant affiche 136 alors que cela aurait dû être 134. Le saut de pas se produit 14 km/h ou 7 pas plus loin. Ton explication sur << l'arrondi >> (c'est le terme qui convient, non ?) de la vitesse d'activation du régulateur/limiteur ne me satisfait pas car, d'après moi, cet arrondi se fait au moment de l'affichage (dans mon exemple 122 alors que l'aiguille indiquait entre 120 122 km/h) ce qui est tout à fait normal : transformation d'une valeur réelle (avec décimales) en une valeur entière (pas de 2) implique d'arrondir. Une fois la valeur de départ déterminée, il n'y a pas de raison que l'on saute des pas puique l'on ajoute (ou retranche) une constante.

Ou alors je n'ai pas compris ton explication...

Pour info, en mode régulateur, pour 120 en consigne, l'aiguille du compteur est pile-poil sur 120 km/h. Il y a une réelle différence de position d'aiguille entre 132, 134 et 136 km/h.

A+
Tux


Bon je ne voulais pas trop rentrer dans le détail, mais voici le fin mot de l'histoire :
- la vitesse mémorisée dans le calculateur d'injection n'est PAS arrondie, c'est toujours un chiffre avec des virgules, et très important : c'est la vitesse RELLE du véhicule
- la vitesse affichée au tableau est une vitesse MAJOREE, donc supérieure à la vitesse réelle, puis ARRONDIE à la vitesse paire la plus proche. C'est ça la fameuse transformation.
- la vitesse sur laquelle on fait les +/- 2 km/h est la vitesse réelle connue du calculateur d'injection.

Sachant cela, prenons ton exemple :
- tu actives le régulateur à la vitesse REELLE de 119.7
- admettons que la vitesse MAJOREE soit de 120.5 (je ne connais pas les vraies valeurs, disons qu'elle majore de 0.8 km/h...)
- l'arrondi à la valeur paire donne 120 -> OK
- tu fais 6 appuis +
- la vitesse REELLE de regul devient 119.7 + 12 = 131.7
- admettons que dans ce cas la vitesse MAJOREE vaut 132.9 (on majore un peu plus, de 1.2 km/h...)
- l'arrondi à la valeur paire donne 132 -> OK
- tu fais encore un appui +
- la vitesse RELLE de regul passe à 133.7
- mais là la vitesse MAJOREE progresse plus vite pour je ne sais quelle raison (disons +1.4 km/h) et elle vaut 135.1
- l'arrondi à la valeur paire donne alors 136 !

Bah alors, il est où mon 134 km/h ? Mangé ! CQFD : mauvaise conception entre les vitesses de régulation et d'affichage, qui ne sont en fait pas les mêmes.
Douggy
Membre d'honneur
Message Mer 06 Avr, 2005 10:04
Up. Le post de dizaines de pages meli-melo a été scindé (Ici, le problème traité n'est QUE celui du saut de vitesse (ex : 128.130.134...136)

Bonne lecture. :wink:
_________________
===============
Ex : R6, R18, Clio, Clio (Bis), Nissan Sunny, Mercedes e220+Twingo, Jeep GdCherokee, Jeep GdCherokee (Bis), BMW530d,
Retour à Rino avec une VelSatis 2.2dci150 Initiale Ici
Actuellement : Nissan Pathfinder Ici + Citroen C1
Futur : x5 3.5i Ici
Le seule moyen que j'aie trouvé pour avoir le 134, c'est d'enclenché (bouton + du volant) quand j'étais à peu près à cette vitesse. une fois que ca été mémorisé, on peut monter et descendre à volonté et en passant par 134.

Ce qui est dingue, c'est que ce problème existe depuis les premières Lag :evil:
_________________
Si je suis l'explication de Bouboune, tu as un écart entre la vitesse réelle et la vitesse affichée. L'arrondi conduit à faire un arrondi sur la vitesse affichée.

A chaque appui sur le bouton, on fait +2 km/ sur la vitesse réelle et de temps en temps on saute un pas de 2 km/h sur la vitesse affichée.
En montant par incrémentation, il y a plusieurs valeurs de vitesse qui sautent si bien qu'au bout d'un certain temps l'écart avec entre vitesse réelle et affichée va être arrondi à +2 puis +4 puis +6....

Est-ce bien celà ?
_________________
Carminas
Grand Espace IV Privilège 2.0T 165CV Vert Amande + 2 sièges AR + 6 stores pare-soleil + Galerie de toit (11/2003)
puis
Espace IV Expression 1.9dCi 117CV Gris Platine + 1 siège AR + 2 stores pare-soleil + Lunette AR ouvrante + Carte mains libres + Vitres AR surteintées + Régulateur limiteur de vitesse + Essuie-vitres automatique avec capteur de pluie (05/2005)
puis
Espace IV Carminat 2.0dCi 130CV Beige Angora + 1 siège AR + 2 stores pare-soleil + Lunette AR ouvrante + Vitres AR surteintées + Toit ouvrant électrique panoramique (04/2007)
et pour le limiteur???????
_________________
Laguna II ph.2 2005, GT 2.0T (+GPL) onado estate, toit ouvrant, Carminat, Radar de recul
ex : Lag II phase 1 dCi 120 privilège, 11/2001, gris eclipse, 118 500km
ex2 : Lag II phase 1 dCi 110, expression, vert amande, 70 000 km
Parents, avant : R5, super 5, R11, R19, R19 ph2, Clio, puis... rien pendant 5 ans expatriement oblige
Bouboune a écrit:
tuxcarnav a écrit:
Bouboune a écrit:

Encore un problème de communication de la part de Renault : ce dysfonctionnement n'est pas un bug de logiciel ! C'est une mauvaise conception de la fonction qui transforme la vitesse réelle enregistrée lors de l'activation du régulateur (cette vitesse n'est pas un entier, il y a une virgule et des chiffres derrière) en une vitesse paire affichable au tableau de bord. Cette transformation a mal été conçue, mais le logiciel est lui parfaitement conforme, et bête et méchant il reproduit le phénomène, qui n'est pas grave certes, mais ne fait vraiment pas très sérieux, je te l'accorde !


Salut,

Par exemple (vécu récemment) : je roule à une vitesse proche de 120 km/h, je sélectionne le limiteur, j'appuie sur [+], l'afficheur indique 122. Je décide de mettre la consigne à 134 km/h, à l'aide de la touche [+] j'augmente la vitesse de consigne, dans le même temps je ne touche pas à l'accélérateur et la voiture reste autour de 120 km/h. Jusqu'à 132, pas de problème, mais l'appui suivant affiche 136 alors que cela aurait dû être 134. Le saut de pas se produit 14 km/h ou 7 pas plus loin. Ton explication sur << l'arrondi >> (c'est le terme qui convient, non ?) de la vitesse d'activation du régulateur/limiteur ne me satisfait pas car, d'après moi, cet arrondi se fait au moment de l'affichage (dans mon exemple 122 alors que l'aiguille indiquait entre 120 122 km/h) ce qui est tout à fait normal : transformation d'une valeur réelle (avec décimales) en une valeur entière (pas de 2) implique d'arrondir. Une fois la valeur de départ déterminée, il n'y a pas de raison que l'on saute des pas puique l'on ajoute (ou retranche) une constante.

Ou alors je n'ai pas compris ton explication...

Pour info, en mode régulateur, pour 120 en consigne, l'aiguille du compteur est pile-poil sur 120 km/h. Il y a une réelle différence de position d'aiguille entre 132, 134 et 136 km/h.

A+
Tux


Bon je ne voulais pas trop rentrer dans le détail, mais voici le fin mot de l'histoire :
- la vitesse mémorisée dans le calculateur d'injection n'est PAS arrondie, c'est toujours un chiffre avec des virgules, et très important : c'est la vitesse RELLE du véhicule
- la vitesse affichée au tableau est une vitesse MAJOREE, donc supérieure à la vitesse réelle, puis ARRONDIE à la vitesse paire la plus proche. C'est ça la fameuse transformation.
- la vitesse sur laquelle on fait les +/- 2 km/h est la vitesse réelle connue du calculateur d'injection.

Sachant cela, prenons ton exemple :
- tu actives le régulateur à la vitesse REELLE de 119.7
- admettons que la vitesse MAJOREE soit de 120.5 (je ne connais pas les vraies valeurs, disons qu'elle majore de 0.8 km/h...)
- l'arrondi à la valeur paire donne 120 -> OK
- tu fais 6 appuis +
- la vitesse REELLE de regul devient 119.7 + 12 = 131.7
- admettons que dans ce cas la vitesse MAJOREE vaut 132.9 (on majore un peu plus, de 1.2 km/h...)
- l'arrondi à la valeur paire donne 132 -> OK
- tu fais encore un appui +
- la vitesse RELLE de regul passe à 133.7
- mais là la vitesse MAJOREE progresse plus vite pour je ne sais quelle raison (disons +1.4 km/h) et elle vaut 135.1
- l'arrondi à la valeur paire donne alors 136 !

Bah alors, il est où mon 134 km/h ? Mangé ! CQFD : mauvaise conception entre les vitesses de régulation et d'affichage, qui ne sont en fait pas les mêmes.



Salut Bouboune

Hier en utilisant le régulateur de la Mégane Luxe Privilège d'avril 2004, j'ai eu la désagréable surprise de m'apercevoir qu'en appuyant sur les touches + et - , je passais de 130 à 134KM/H !

J'ai lu ton explication et si j'ai bien compris, il n' y a rien à faire hormis réussir à enclencher le régulateur sur une vitesse bien précise, de manière à ne pas se retrouver avec des chiffres après la virgule ! C'est donc ce que j'avais toujours réussi à faire depuis que j'ai ma voiture car le régulateur a toujours fonctionné correctement !!
Mon véhicule étant encore sous garantie, n'est il pas judicieux de le ramener chez Renault ? et si non, que faire pour éviter ce genre de dégagrément et n' y a t'il pas risque que cela se multiplie ?

Merci pour tes éclaircissements
Non, en général ça arrive que sur 2 vitesses. J'ai eu 2 LagII (05/2004 et 12/2004) et les deux avait des pbs sur le 94 et la 134 mais pas ailleurs. Pour d'autres personnes c'est à 2 autres endroits.
Si tu veux avoir vraiment le 134, par exemple, désenclenche et réenclenche la mémorisation de la vitesse plusieurs fois; au pire au bout de 3 fois tu affiches le 134. Et tant que tu ne coupe pas le régulateur avec O tu obtiendras toujors ce 134 sans pbs.
Pas gênant, y a vraiment plus embêtant sur une Renault :x que ça!
_________________
DID2T

ADIEU la Lag
12/2006 - C5 II Break 138 Hdi Exclusive
DID2T a écrit:
Non, en général ça arrive que sur 2 vitesses. J'ai eu 2 LagII (05/2004 et 12/2004) et les deux avait des pbs sur le 94 et la 134 mais pas ailleurs. Pour d'autres personnes c'est à 2 autres endroits.
Si tu veux avoir vraiment le 134, par exemple, désenclenche et réenclenche la mémorisation de la vitesse plusieurs fois; au pire au bout de 3 fois tu affiches le 134. Et tant que tu ne coupe pas le régulateur avec O tu obtiendras toujors ce 134 sans pbs.
Pas gênant, y a vraiment plus embêtant sur une Renault :x que ça!


le 134km/h je l'ai, hier c'est le 132 qui s'est fait la belle et je vais essayer demain pour voir si c'est revenu et si j'ai le 94 !
Si ce n'est pas le cas, je poserai la question à la concession Renault mais bon, je doute avoir une réponse !
Aloha,

Merci les gars!

ca me taquinais ce truc là, j'avais l'impression d'avoir un bug, mais puisque tout le monde l'a, je considère qu'il s'agit d'une fonctionnalité non-documentée et je laisserai tranquille mon Renault-minute !
Idem sur ma clio... des sauts de vitesse avec le régulateur, mais il me semble que c'est toujours les mêmes vitesses qui sont absentes et pas aléatoirement, Faudra que je réassai quand ça me le fait de désenclencher puis de réenclencher le régulateur de vitesse pour voir si ces "sauts" disparaissent... :roll:
_________________
Ex Clio II Initiale DCI100
Ex Mégane DCI120 Confort Authentique
Scénic III Privilège DCI 110 EDC Black avec pack xénon arrivé le 18/04/2011! :)
JefD
Membre d'honneur
Message Jeu 19 Jan, 2006 13:01
Je ne suis pas sûr que j'ai le même régulateur :shock:

J'ai très peu de problèmes de saut... Je peux facilement obtenir toutes les vitesse de 70 à 130 (je ne le mets pas plus haut)... et même en faisant des sauts de 2 en 2, je vois bien défiler toutes les vitesses systématiquement :shock:
Le seul hic, c'est pour le 50... Si je ne suis pas exactement à 50 pour mettre le régulateur, il s'enclenche à 48 ou 52... et c'en est fini du 50... Mais le hic de l'histoire, c'est que c'est systématique...

PS : Ca m'arrive souvent d'enclencher le régulateur à 70, puis d'augmenter petit à petit jusque 130 (avec interruption vers 90 pour passage en 6ème) et je n'ai observé que extrêmement rarement un saut de vitesse. L'énorme majorité du temps, c'est en continu de 70 à 130 :shock:

En confrontant mon cas avec l'explication, je ne suis pas aussi sûr que cela du raisonnement expliqué :? ... Ca ma paraît assez suspect de ne pas voir de saut de vitesse sur une plage de 60 km/h (de 70 à 130) et d'avoir systématiquement un saut de vitesse sur une plage de 4 km/h (autour de 50)
tnt a écrit:
Aloha,

Merci les gars!

ca me taquinais ce truc là, j'avais l'impression d'avoir un bug, mais puisque tout le monde l'a, je considère qu'il s'agit d'une fonctionnalité non-documentée et je laisserai tranquille mon Renault-minute !


Exact et tu peux être rassuré car c'est bien un "problème" lié au fait que le calculateur ne sait pas trouver le chiffres à venir, dès lors que le régulateur est enclenché quand ta vitesse réelle n'est pas ronde (chiffres après la virgule), dès lors, il chinte la vitesse mise en mémoire et passe à l'autre ! Cependant si tu enclenches à une vitesse ronde, pas de problème, il affiche toutes les vitesses de 2km en 2 km ! J'ai essayé et pour moi, tout est rentré dans l'ordre et ce phénomène m'a été confirmé par le service clientèle de Renault Boulogne Billancourt :wink:
Cool ! je vais essayer le contournement.

D'autant plus que si cela arrivait a 162 km/h ce ne serait pas grave mais a 130/132/134 on doit rentrer dans la psychose Sarkozienne !
Tu veux rouler un peu plus que 130 et tu te retrouve a 136 ! Et flash! un "Cécile-de-minibus" avec un conducteur ahuri dans la boîte !

Je tacherai de l'engager a une vitesse "ronde"
tnt a écrit:
Cool ! je vais essayer le contournement.

D'autant plus que si cela arrivait a 162 km/h ce ne serait pas grave mais a 130/132/134 on doit rentrer dans la psychose Sarkozienne !
Tu veux rouler un peu plus que 130 et tu te retrouve a 136 ! Et flash! un "Cécile-de-minibus" avec un conducteur ahuri dans la boîte !

Je tacherai de l'engager a une vitesse "ronde"


:lol: :lol: :lol:

Tu verras cela devrai marcher correctement !!

Ce problème de chiffres après la virgule entraînant le chintage par le calculateur du chiffre rond arrivant après m'a été confirmé par un technicien de chez Renault Boulogne Billancourt qui m'a d'ailleurs indiqué que cela était valable pour l'ensemble des régulateurs, les calculateurs n'ayant pa été programmer pour travailler avec des chiffres à virgule ! donc tout est OK

Par contre, il me confirme que la présence de goutelettes de condensation dans mes phares n'est pas normale donc opération changement !!
j'ajouterai que le decalage entre la vitesse compteur et la vitesse reelle est obligatoire pour l'homologation et que cette difference est croissante avec la vitesse,donc a un certain moment vous passez par un supplement de +2km/h
Message Sam 16 Aoû, 2008 10:08
hello, ;)

s est peut etre bête mais comment savoir avec certitude que l on se cale a une vitesse ronde?

merci a+ ;)


Sauter vers: 



Dernières news